First commit.
This commit is contained in:
commit
ba0663e2ac
21 changed files with 788 additions and 0 deletions
37
sys-firmware/iptsd/files/meson.patch
Normal file
37
sys-firmware/iptsd/files/meson.patch
Normal file
|
@ -0,0 +1,37 @@
|
|||
diff -Naur iptsd-master/meson.build edited_iptsd/meson.build
|
||||
--- iptsd-master/meson.build 2021-04-24 20:12:52.070042255 +0700
|
||||
+++ edited_iptsd/meson.build 2021-04-24 20:08:27.490024110 +0700
|
||||
@@ -101,8 +101,7 @@
|
||||
configuration: conf
|
||||
)
|
||||
|
||||
-service_manager = get_option('service_manager')
|
||||
-if service_manager.contains('systemd')
|
||||
+if get_option('systemd')
|
||||
systemd = dependency('systemd')
|
||||
unitdir = systemd.get_pkgconfig_variable('systemdsystemunitdir')
|
||||
|
||||
@@ -116,9 +115,7 @@
|
||||
)
|
||||
|
||||
install_data('etc/udev/50-ipts.rules', install_dir: rulesdir)
|
||||
-endif
|
||||
-
|
||||
-if service_manager.contains('openrc')
|
||||
+else
|
||||
dependency('openrc')
|
||||
openrcdir = join_paths(sysconfdir, 'init.d')
|
||||
|
||||
diff -Naur iptsd-master/meson_options.txt edited_iptsd/meson_options.txt
|
||||
--- iptsd-master/meson_options.txt 2021-04-24 20:11:30.566703332 +0700
|
||||
+++ edited_iptsd/meson_options.txt 2021-04-24 20:08:45.850025371 +0700
|
||||
@@ -1,8 +1,3 @@
|
||||
-option(
|
||||
- 'service_manager',
|
||||
- type: 'array',
|
||||
- choices: ['systemd', 'openrc'],
|
||||
- value: ['systemd']
|
||||
-)
|
||||
+option('systemd', type: 'boolean', value: false)
|
||||
option('sample_config', type: 'boolean', value: true)
|
||||
option('debug_tool', type: 'boolean', value: true)
|
49
sys-firmware/iptsd/iptsd-0.4.ebuild
Normal file
49
sys-firmware/iptsd/iptsd-0.4.ebuild
Normal file
|
@ -0,0 +1,49 @@
|
|||
# Copyright 2021 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
inherit meson
|
||||
inherit eutils
|
||||
inherit ninja-utils
|
||||
|
||||
DESCRIPTION="Userspace daemon for Intel Precise Touch & Stylus"
|
||||
HOMEPAGE="https://github.com/linux-surface/iptsd"
|
||||
SRC_URI="https://github.com/linux-surface/iptsd/archive/refs/heads/master.zip"
|
||||
|
||||
LICENSE="GPL-2+"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE="systemd"
|
||||
|
||||
DEPEND="dev-libs/inih"
|
||||
RDEPEND="${DEPEND}"
|
||||
BDEPEND="dev-util/ninja sys-devel/gcc dev-util/meson"
|
||||
|
||||
src_unpack() {
|
||||
unpack ${DISTDIR}/master.zip
|
||||
}
|
||||
|
||||
S="${WORKDIR}/${PN}-master"
|
||||
|
||||
src_prepare() {
|
||||
eapply "${FILESDIR}/meson.patch"
|
||||
eapply_user
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
local emesonargs=(
|
||||
$(meson_use systemd)
|
||||
)
|
||||
meson_src_configure
|
||||
}
|
||||
|
||||
src_compile() {
|
||||
meson_src_compile
|
||||
eninja -C ${WORKDIR}/${P}-build
|
||||
}
|
||||
|
||||
src_install() {
|
||||
DESTDIR="${D}" eninja -C ${WORKDIR}/${P}-build install
|
||||
#ninja -C ${WORKDIR}/${P}-build install
|
||||
}
|
Loading…
Add table
Add a link
Reference in a new issue