Version bump, added dependencies, and fixed compile errors.
This commit is contained in:
parent
4d98b4935e
commit
7c95c3bf97
8 changed files with 139 additions and 98 deletions
41
dev-cpp/CLI11/CLI11-2.3.2.ebuild
Normal file
41
dev-cpp/CLI11/CLI11-2.3.2.ebuild
Normal file
|
@ -0,0 +1,41 @@
|
||||||
|
# Copyright 1999-2023 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=7
|
||||||
|
|
||||||
|
inherit cmake
|
||||||
|
|
||||||
|
DESCRIPTION="A command line parser for C++11"
|
||||||
|
HOMEPAGE="https://github.com/CLIUtils/CLI11"
|
||||||
|
SRC_URI="https://github.com/CLIUtils/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||||
|
|
||||||
|
LICENSE="BSD"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~amd64 ~x86"
|
||||||
|
IUSE="examples test"
|
||||||
|
|
||||||
|
RESTRICT="!test? ( test )"
|
||||||
|
|
||||||
|
DEPEND=""
|
||||||
|
RDEPEND=""
|
||||||
|
|
||||||
|
src_configure() {
|
||||||
|
local mycmakeargs=(
|
||||||
|
-DCLI11_BUILD_EXAMPLES=$(usex examples)
|
||||||
|
-DCLI11_BUILD_TESTS=$(usex test)
|
||||||
|
)
|
||||||
|
cmake_src_configure
|
||||||
|
}
|
||||||
|
|
||||||
|
src_compile() {
|
||||||
|
cmake_src_compile
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
cmake_src_install
|
||||||
|
if use examples; then
|
||||||
|
dodoc -r examples
|
||||||
|
docompress -x /usr/share/doc/${PF}/examples
|
||||||
|
fi
|
||||||
|
}
|
||||||
|
|
2
sys-firmware/iptsd/files/iptsd.conf
Normal file
2
sys-firmware/iptsd/files/iptsd.conf
Normal file
|
@ -0,0 +1,2 @@
|
||||||
|
d /run/ipts 0755 root root
|
||||||
|
|
12
sys-firmware/iptsd/files/iptsd.service
Normal file
12
sys-firmware/iptsd/files/iptsd.service
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
[Unit]
|
||||||
|
Description=Intel Precise Touch & Stylus Daemon
|
||||||
|
After=multi-user.target
|
||||||
|
|
||||||
|
[Service]
|
||||||
|
ExecStart=/usr/bin/iptsd
|
||||||
|
Restart=on-failure
|
||||||
|
User=root
|
||||||
|
|
||||||
|
[Install]
|
||||||
|
WantedBy=multi-user.target
|
||||||
|
|
|
@ -1,49 +0,0 @@
|
||||||
# Copyright 2021 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=7
|
|
||||||
|
|
||||||
inherit meson
|
|
||||||
inherit eutils
|
|
||||||
inherit ninja-utils
|
|
||||||
|
|
||||||
DESCRIPTION="Userspace daemon for Intel Precise Touch & Stylus"
|
|
||||||
HOMEPAGE="https://github.com/linux-surface/iptsd"
|
|
||||||
SRC_URI="https://github.com/linux-surface/iptsd/archive/refs/heads/master.zip"
|
|
||||||
|
|
||||||
LICENSE="GPL-2+"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~x86"
|
|
||||||
IUSE="systemd"
|
|
||||||
|
|
||||||
DEPEND="dev-libs/inih"
|
|
||||||
RDEPEND="${DEPEND}"
|
|
||||||
BDEPEND="dev-util/ninja sys-devel/gcc dev-util/meson"
|
|
||||||
|
|
||||||
src_unpack() {
|
|
||||||
unpack ${DISTDIR}/master.zip
|
|
||||||
}
|
|
||||||
|
|
||||||
S="${WORKDIR}/${PN}-master"
|
|
||||||
|
|
||||||
src_prepare() {
|
|
||||||
eapply "${FILESDIR}/meson.patch"
|
|
||||||
eapply_user
|
|
||||||
}
|
|
||||||
|
|
||||||
src_configure() {
|
|
||||||
local emesonargs=(
|
|
||||||
$(meson_use systemd)
|
|
||||||
)
|
|
||||||
meson_src_configure
|
|
||||||
}
|
|
||||||
|
|
||||||
src_compile() {
|
|
||||||
meson_src_compile
|
|
||||||
eninja -C ${WORKDIR}/${P}-build
|
|
||||||
}
|
|
||||||
|
|
||||||
src_install() {
|
|
||||||
DESTDIR="${D}" eninja -C ${WORKDIR}/${P}-build install
|
|
||||||
#ninja -C ${WORKDIR}/${P}-build install
|
|
||||||
}
|
|
|
@ -1,49 +0,0 @@
|
||||||
# Copyright 2021 Gentoo Authors
|
|
||||||
# Distributed under the terms of the GNU General Public License v2
|
|
||||||
|
|
||||||
EAPI=7
|
|
||||||
|
|
||||||
inherit meson
|
|
||||||
inherit eutils
|
|
||||||
inherit ninja-utils
|
|
||||||
|
|
||||||
DESCRIPTION="Userspace daemon for Intel Precise Touch & Stylus"
|
|
||||||
HOMEPAGE="https://github.com/linux-surface/iptsd"
|
|
||||||
SRC_URI="https://github.com/linux-surface/iptsd/archive/refs/heads/master.zip"
|
|
||||||
|
|
||||||
LICENSE="GPL-2+"
|
|
||||||
SLOT="0"
|
|
||||||
KEYWORDS="~amd64 ~x86"
|
|
||||||
IUSE="systemd"
|
|
||||||
|
|
||||||
DEPEND="dev-libs/inih"
|
|
||||||
RDEPEND="${DEPEND}"
|
|
||||||
BDEPEND="dev-util/ninja sys-devel/gcc dev-util/meson"
|
|
||||||
|
|
||||||
src_unpack() {
|
|
||||||
unpack ${DISTDIR}/master.zip
|
|
||||||
}
|
|
||||||
|
|
||||||
S="${WORKDIR}/${PN}-master"
|
|
||||||
|
|
||||||
src_prepare() {
|
|
||||||
eapply "${FILESDIR}/meson.patch"
|
|
||||||
eapply_user
|
|
||||||
}
|
|
||||||
|
|
||||||
src_configure() {
|
|
||||||
local emesonargs=(
|
|
||||||
$(meson_use systemd)
|
|
||||||
)
|
|
||||||
meson_src_configure
|
|
||||||
}
|
|
||||||
|
|
||||||
src_compile() {
|
|
||||||
meson_src_compile
|
|
||||||
eninja -C ${WORKDIR}/${P}-build
|
|
||||||
}
|
|
||||||
|
|
||||||
src_install() {
|
|
||||||
DESTDIR="${D}" eninja -C ${WORKDIR}/${P}-build install
|
|
||||||
#ninja -C ${WORKDIR}/${P}-build install
|
|
||||||
}
|
|
33
sys-firmware/iptsd/iptsd-1.2.0.ebuild
Normal file
33
sys-firmware/iptsd/iptsd-1.2.0.ebuild
Normal file
|
@ -0,0 +1,33 @@
|
||||||
|
# Copyright 1999-2023 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=7
|
||||||
|
|
||||||
|
inherit meson systemd
|
||||||
|
|
||||||
|
DESCRIPTION="A userspace daemon for the Intel Precise Touch & Stylus technology"
|
||||||
|
HOMEPAGE="https://github.com/linux-surface/iptsd"
|
||||||
|
SRC_URI="https://github.com/linux-surface/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
|
||||||
|
|
||||||
|
LICENSE="GPL-2"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~amd64"
|
||||||
|
IUSE=""
|
||||||
|
|
||||||
|
DEPEND="dev-libs/hidapi dev-cpp/CLI11 dev-libs/spdlog sys-libs/hidrd"
|
||||||
|
RDEPEND="${DEPEND}"
|
||||||
|
|
||||||
|
src_configure() {
|
||||||
|
#local emesonargs=(
|
||||||
|
# -Dsystemd=enabled
|
||||||
|
# -Dudev=disabled
|
||||||
|
# )
|
||||||
|
meson_src_configure
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
meson_src_install
|
||||||
|
systemd_dounit "${FILESDIR}/iptsd.service"
|
||||||
|
systemd_dotmpfiles "${FILESDIR}/iptsd.conf"
|
||||||
|
}
|
||||||
|
|
12
sys-libs/hidrd/files/fallthrough.patch
Normal file
12
sys-libs/hidrd/files/fallthrough.patch
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
/fmt/xml/snk/element.c
|
||||||
|
--- a/lib/fmt/xml/snk/element.c 2023-04-21 09:23:25.216848044 -0700
|
||||||
|
+++ b/lib/fmt/xml/snk/element.c 2023-04-21 09:24:15.893725175 -0700
|
||||||
|
@@ -229,6 +229,7 @@
|
||||||
|
case XML_SNK_ELEMENT_NT_ATTR:
|
||||||
|
/* Retrieve name */
|
||||||
|
(void)va_arg(*pap, const char *);
|
||||||
|
+ /* FALLTHROUGH */
|
||||||
|
case XML_SNK_ELEMENT_NT_COMMENT:
|
||||||
|
case XML_SNK_ELEMENT_NT_CONTENT:
|
||||||
|
fmt = va_arg(*pap, hidrd_fmt_type);
|
||||||
|
|
39
sys-libs/hidrd/hidrd-0.2.0.ebuild
Normal file
39
sys-libs/hidrd/hidrd-0.2.0.ebuild
Normal file
|
@ -0,0 +1,39 @@
|
||||||
|
# Copyright 1999-2023 Gentoo Authors
|
||||||
|
# Distributed under the terms of the GNU General Public License v2
|
||||||
|
|
||||||
|
EAPI=7
|
||||||
|
|
||||||
|
inherit autotools flag-o-matic
|
||||||
|
|
||||||
|
DESCRIPTION="A library and tool for processing HID report descriptors"
|
||||||
|
HOMEPAGE="https://github.com/DIGImend/hidrd"
|
||||||
|
SRC_URI="https://github.com/DIGImend/${PN}/releases/download/${PV}/${P}.tar.gz -> ${P}.tar.gz"
|
||||||
|
|
||||||
|
LICENSE="GPL-2"
|
||||||
|
SLOT="0"
|
||||||
|
KEYWORDS="~amd64 ~x86"
|
||||||
|
IUSE=""
|
||||||
|
|
||||||
|
DEPEND="sys-libs/libcap"
|
||||||
|
RDEPEND="${DEPEND}"
|
||||||
|
|
||||||
|
PATCHES=(
|
||||||
|
"${FILESDIR}/fallthrough.patch"
|
||||||
|
)
|
||||||
|
|
||||||
|
src_prepare() {
|
||||||
|
default
|
||||||
|
eautoreconf
|
||||||
|
}
|
||||||
|
|
||||||
|
src_configure() {
|
||||||
|
# Fix multiple definition errors
|
||||||
|
append-flags -fcommon
|
||||||
|
econf
|
||||||
|
}
|
||||||
|
|
||||||
|
src_install() {
|
||||||
|
default
|
||||||
|
find "${D}" -name '*.la' -delete || die
|
||||||
|
}
|
||||||
|
|
Loading…
Add table
Reference in a new issue