Version bump, added dependencies, and fixed compile errors.
This commit is contained in:
parent
4d98b4935e
commit
7c95c3bf97
8 changed files with 139 additions and 98 deletions
12
sys-libs/hidrd/files/fallthrough.patch
Normal file
12
sys-libs/hidrd/files/fallthrough.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
/fmt/xml/snk/element.c
|
||||
--- a/lib/fmt/xml/snk/element.c 2023-04-21 09:23:25.216848044 -0700
|
||||
+++ b/lib/fmt/xml/snk/element.c 2023-04-21 09:24:15.893725175 -0700
|
||||
@@ -229,6 +229,7 @@
|
||||
case XML_SNK_ELEMENT_NT_ATTR:
|
||||
/* Retrieve name */
|
||||
(void)va_arg(*pap, const char *);
|
||||
+ /* FALLTHROUGH */
|
||||
case XML_SNK_ELEMENT_NT_COMMENT:
|
||||
case XML_SNK_ELEMENT_NT_CONTENT:
|
||||
fmt = va_arg(*pap, hidrd_fmt_type);
|
||||
|
39
sys-libs/hidrd/hidrd-0.2.0.ebuild
Normal file
39
sys-libs/hidrd/hidrd-0.2.0.ebuild
Normal file
|
@ -0,0 +1,39 @@
|
|||
# Copyright 1999-2023 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=7
|
||||
|
||||
inherit autotools flag-o-matic
|
||||
|
||||
DESCRIPTION="A library and tool for processing HID report descriptors"
|
||||
HOMEPAGE="https://github.com/DIGImend/hidrd"
|
||||
SRC_URI="https://github.com/DIGImend/${PN}/releases/download/${PV}/${P}.tar.gz -> ${P}.tar.gz"
|
||||
|
||||
LICENSE="GPL-2"
|
||||
SLOT="0"
|
||||
KEYWORDS="~amd64 ~x86"
|
||||
IUSE=""
|
||||
|
||||
DEPEND="sys-libs/libcap"
|
||||
RDEPEND="${DEPEND}"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/fallthrough.patch"
|
||||
)
|
||||
|
||||
src_prepare() {
|
||||
default
|
||||
eautoreconf
|
||||
}
|
||||
|
||||
src_configure() {
|
||||
# Fix multiple definition errors
|
||||
append-flags -fcommon
|
||||
econf
|
||||
}
|
||||
|
||||
src_install() {
|
||||
default
|
||||
find "${D}" -name '*.la' -delete || die
|
||||
}
|
||||
|
Loading…
Add table
Add a link
Reference in a new issue