Testing different cargo options.
This commit is contained in:
parent
c58a37f40e
commit
469126f242
2 changed files with 2 additions and 54 deletions
|
@ -1,48 +0,0 @@
|
||||||
--- a/Cargo.toml 2021-07-30 19:57:48.471382115 -0700
|
|
||||||
+++ b/Cargo.toml 2021-07-30 20:13:26.297811214 -0700
|
|
||||||
@@ -1,10 +1,43 @@
|
|
||||||
-[workspace]
|
|
||||||
+[package]
|
|
||||||
+name = "surface-dtx-daemon"
|
|
||||||
+version = "0.3.0"
|
|
||||||
+authors = ["Maximilian Luz <luzmaximilian@gmail.com>"]
|
|
||||||
+description = "Linux User-Space Detachment System (DTX) Daemon for the Surface ACPI Driver (and Surface Books). Currently only the Surface Book 2 is supported, due to lack of driver-support on the Surface Book 1. This may change in the future."
|
|
||||||
|
|
||||||
members = [
|
|
||||||
"surface-dtx-daemon",
|
|
||||||
"surface-dtx-userd",
|
|
||||||
]
|
|
||||||
|
|
||||||
+repository = "https://github.com/linux-surface/surface-dtx-daemon"
|
|
||||||
+readme = "README.md"
|
|
||||||
+license = "MIT"
|
|
||||||
+
|
|
||||||
+edition = "2018"
|
|
||||||
+build = "build.rs"
|
|
||||||
+
|
|
||||||
+[dependencies]
|
|
||||||
+anyhow = "1.0.40"
|
|
||||||
+clap = "2.33.3"
|
|
||||||
+indoc = "1.0.3"
|
|
||||||
+nix = "0.20.0"
|
|
||||||
+sdtx = { git = "https://github.com/linux-surface/libsurfacedtx", tag = "v0.1.0" }
|
|
||||||
+serde = "1.0.125"
|
|
||||||
+serde_json = "1.0.64"
|
|
||||||
+thiserror = "1.0.24"
|
|
||||||
+udev = "0.6.2"
|
|
||||||
+
|
|
||||||
+[build-dependencies]
|
|
||||||
+anyhow = "1.0.40"
|
|
||||||
+clap = "2.33.3"
|
|
||||||
+indoc = "1.0.3"
|
|
||||||
+nix = "0.20.0"
|
|
||||||
+sdtx = { git = "https://github.com/linux-surface/libsurfacedtx", tag = "v0.1.0" }
|
|
||||||
+serde = "1.0.125"
|
|
||||||
+serde_json = "1.0.64"
|
|
||||||
+thiserror = "1.0.24"
|
|
||||||
+udev = "0.6.2"
|
|
||||||
+
|
|
||||||
[profile.release]
|
|
||||||
lto = true
|
|
||||||
codegen-units = 1
|
|
||||||
|
|
|
@ -19,16 +19,12 @@ BDEPEND=""
|
||||||
EGIT_REPO_URI="https://github.com/linux-surface/surface-dtx-daemon"
|
EGIT_REPO_URI="https://github.com/linux-surface/surface-dtx-daemon"
|
||||||
S="${WORKDIR}/surface-dtx-daemon-9999"
|
S="${WORKDIR}/surface-dtx-daemon-9999"
|
||||||
|
|
||||||
src_prepare() {
|
|
||||||
eapply "${FILESDIR}/cargo.patch"
|
|
||||||
default
|
|
||||||
}
|
|
||||||
|
|
||||||
src_unpack() {
|
src_unpack() {
|
||||||
git-r3_src_unpack
|
git-r3_src_unpack
|
||||||
cargo_live_src_unpack
|
cargo_live_src_unpack
|
||||||
}
|
}
|
||||||
|
|
||||||
src_compile() {
|
src_compile() {
|
||||||
cargo_src_compile --locked
|
cargo_src_compile --locked surface-dtx-daemon
|
||||||
|
cargo_src_compile --locked surface-dtx-userd
|
||||||
}
|
}
|
||||||
|
|
Loading…
Add table
Reference in a new issue