Added patch for cargo.

This commit is contained in:
Ronald Farrer 2021-07-30 20:09:29 -07:00
parent 6974b84627
commit 2d607c1774
2 changed files with 20 additions and 0 deletions

View file

@ -0,0 +1,16 @@
--- Cargo.toml 2021-07-30 20:02:29.337028884 -0700
+++ Cargo.toml.new 2021-07-30 20:06:19.254133528 -0700
@@ -1,10 +1,10 @@
[package]
-name = "surface"
-version = "0.4.1"
+name = "surface-dtx-daemon"
+version = "0.3.0"
authors = ["Maximilian Luz <luzmaximilian@gmail.com>"]
-description = "Control various aspects of Microsoft Surface devices on Linux from the Command-Line"
+description = "Linux User-Space Detachment System (DTX) Daemon for the Surface ACPI Driver (and Surface Books). Currently only the Surface Book 2 is supported, due to lack of driver-support on the Surface Book 1. This may change in the future."
-repository = "https://github.com/linux-surface/surface-control"
+repository = "https://github.com/linux-surface/surface-dtx-daemon"
readme = "README.md"
license = "MIT"

View file

@ -19,6 +19,10 @@ BDEPEND=""
EGIT_REPO_URI="https://github.com/linux-surface/surface-dtx-daemon"
S="${WORKDIR}/surface-dtx-daemon-9999"
src_prepare() {
epatch "${FILESDIR}/cargo.patch"
}
src_unpack() {
git-r3_src_unpack
cargo_live_src_unpack